Usar BUSCARV con dos o más condiciones


ExcelLos que seguís mi blog sabéis de mi pasión por el programa Excel de la suite de Microsoft Office. Lo uso a diario y no paro de aprender cosas nuevas, algunas interesantes y casi siempre super útiles. Si en alguna ocasión habéis empleado la función BUSCARV de Excel, ¿no habéis echado en falta realizar una búsqueda más avanzada, por ejemplo, con dos o más condiciones?

En este articulo os voy a enseñar una forma muy sencilla de hacerlo. Sé que hay otras, pero son más enrevesadas y conducen al mismo objetivo.

BUSCARV es una función tremendamente útil, pero tiene una limitación, que es cuando queremos realizar una búsqueda con más de una condición. Os recuerdo que los parámetros de BUSCARV son:

BUSCARV(valor_buscado; matriz_donde_buscar; columna_devuelta; tipo_busqueda)

Donde:

Valor buscado: es la celda que queremos buscar en la primera columna de la matriz

Matriz donde buscar: es el conjunto de columnas donde realiza la búsqueda, considerando solo la primera columna

Columna devuelta es el numero de columna del que queremos obtener la búsqueda

Tipo de búsqueda es si queremos que la búsqueda sea exacta o aproximada

Podéis leer mi articulo al respecto en este mismo blog, para conocer algo más esta impresionante función.

Partamos de este ejemplo:

Usar BUSCARV con dos o más condiciones

Queremos buscar el valor Orden de Impresión correspondiente a Ventiladores anticondensación. Para ello hacemos:

=BUSCARV(G1;B:D;3;0)

Nos devuelve 11 que es el primer valor que encuentra en la 3ª columna correspondiente a la condición puesta. Pero, ¿y si queremos establecer una segunda condición? Por ejemplo que el valor de Unidad sea W. Muy sencillo.

Para ello vamos a ayudarnos de una columna auxiliar que sea la concatenación de las columnas de búsqueda. Pero la tenemos que poner como primera columna de la matriz de búsqueda, aunque la ocultemos luego.

En la columna B ponemos: =C2&D2

Y arrastramos esa formula hacia abajo.

Usar BUSCARV con dos o más condiciones

 

Ahora escribimos la fórmula:

=BUSCARV(G1&G2;B:E;4;0)

Donde:

  • el primer parámetro es la concatenación de las dos condiciones, l
  • a matriz donde realizará la búsqueda está compuesta por 4 columnas donde el valor buscado está en la primera
  • y el devuelto en la cuarta y buscamos búsqueda exacta, por lo que ponemos un 0.

Usar BUSCARV con dos o más condiciones

Cómo supongo que os surgirán algunas preguntas, no dudéis en consultarlas.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Salir /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Salir /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Salir /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Salir /  Cambiar )

Conectando a %s

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios .

Sitio web ofrecido por WordPress.com.

Subir ↑

A %d blogueros les gusta esto: