La función BuscarX en Excel


excel-logoEn esta ocasión os traigo algo muy novedoso, tanto que probablemente aún no esté disponible en vuestra versión de Microsoft Office. Puedes usar la función BUSCARX cuando necesites encontrar elementos en una tabla o en un rango por filas. Por ejemplo, puedes buscar el precio de una pieza de automóvil por el número de pieza o buscar un nombre de empleado en función de su ID. de empleado. Con BUSCARX, puedes buscar en una columna un término de búsqueda y devolver un resultado de la misma fila en otra columna, independientemente de en qué lado se encuentre la columna devuelta.

Nota: Esta función está disponible actualmente para los suscriptores de Microsoft 365 en el canal mensual. Estará disponible para los suscriptores de Microsoft 365 en el canal semianual a partir de julio de 2020.

Sintaxis.

La función BUSCARX busca un rango o una matriz y devuelve un elemento que corresponde a la primera coincidencia que encuentra. Si no hay ninguna coincidencia, BUSCARX puede devolver la coincidencia más cercana (aproximada).

=BUSCARX(valor_buscado; matriz_buscada; matriz_devuelta; [si_no_se_encuentra]; [modo_de_coincidencia]; [modo_de_búsqueda])
Argumento Descripción
valor_buscado

Requerido

El valor buscado
matriz_buscada

Requerido

La matriz o rango para buscar
matriz_devuelta

Requerido

La matriz o rango para devolver
[si_no_se_encuentra]

Opcional

Si no se encuentra una coincidencia válida, devolver el texto [if_not_found] que proporcione.

Si no se encuentra una coincidencia válida y no hay [if_not_found], se devolverá #N/A.

[modo_de_coincidencia]

Opcional

Especifique el tipo de coincidencia:

0: coincidencia exacta. Si no se encuentra ninguno, devolver #N/A. Este valor es el predeterminado.

-1: coincidencia exacta. Si no se encuentra ninguna, devolver el siguiente elemento más pequeño.

1: coincidencia exacta. Si no se encuentra ninguna, devolver el siguiente elemento más grande.

2: una coincidencia comodín donde *, ? y ~ tienen significado especial.

[modo_de_búsqueda]

Opcional

Especifique el modo de búsqueda que se usará:

1: realizar una búsqueda empezando por el primer elemento. Este valor es el predeterminado.

-1: realizar una búsqueda inversa empezando por el último elemento.

2: realizar una búsqueda binaria que se base en que lookup_array se ordene en orden ascendente. Si no está ordenada, se devolverán resultados no válidos.

-2: realizar una búsqueda binaria que se base en que lookup_array se ordene en orden descendente. Si no está ordenada, se devolverán resultados no válidos.

Ejemplo 1.

Este ejemplo usa una función BUSCARX sencilla para buscar un nombre de país y devolver el prefijo telefónico del país. Solo se incluyen los argumentos valor_buscado (celda E2), matriz buscada (rango A2:A11) y matriz_devuelta (rango C2:C11). No incluye el argumento modo_de_coincidencia, ya que de forma predeterminada BUSCARX usa una coincidencia exacta.

BuscarX_ejemplo1

Nota: BUSCARX se diferencia de BUSCARV en que usa matrices de búsqueda y devolución distintas, mientras que BUSCARV usa una sola matriz de tablas seguida de un número de índice de la columna. La fórmula equivalente de BUSCARV en este caso sería: =BUSCARV(E2;A2:C11;3;FALSE)

Ejemplo 2.

En este ejemplo, estamos buscando información de un empleado basada en un número de identificación de empleado. Al contrario que BUSCARV, BUSCARX puede devolver una matriz con varios elementos, lo que permite que una sola fórmula devuelva tanto el nombre del empleado como el de un departamento de las celdas C5:D12.

BuscarX_ejemplo2

Ejemplo 3.

Este ejemplo agrega el argumento Si_no_se_encuentra al ejemplo anterior.

BuscarX_ejemplo3

Ejemplo 4.

En el ejemplo siguiente se busca en la columna C los ingresos personales especificados en la celda E2 y se encuentra un tipo impositivo coincidente en la columna B. Establece el argumento Si_no_se_encuentra para devolver 0 si no se encuentra nada. El argumento modo_de_coincidencia está establecido en 1, lo que significa que la función buscará una coincidencia exacta y, si no encuentra una, devolverá el siguiente elemento más grande. Por último, el argumento modo_de_búsqueda está establecido en 1, lo que significa que la función buscará desde el primer elemento hasta el último.

BuscarX_ejemplo4

Nota: Al contrario que BUSCARV, la columna matriz_buscada se encuentra a la derecha de la columna matriz_devuelta, donde BUSCARV solo puede buscar de izquierda a derecha.

Ejemplo 5.

Luego, usaremos una función anidada BUSCARX para realizar una coincidencia vertical y otra horizontal. En este caso buscará, en primer lugar, Ingresos brutos en la columna B y después buscará Trim1 en la fila superior de la tabla (rango C5:F5) y devolverá el valor en la intersección de los dos. Esto es similar a usar las funciones INDICE y COINCIDIR conjuntamente. También puede usar BUSCARX para reemplazar la función BUSCARH.

BuscarX_ejemplo5

La fórmula en las celdas D3:F3 es: =BUSCARX(D2;$B6:$B17;BUSCARX($C3;$C5:$G5;$C6:$G17)).

Ejemplo 6.

Este ejemplo usa la función SUMA y dos funciones BUSCARX anidadas para sumar todos los valores entre dos rangos. En este caso, queremos sumar los valores de uvas, plátanos e incluir peras, que están entre ambos.

BuscarX_ejemplo6

La fórmula de la celda D3 es: =SUMA(BUSCARX(B3;B6:B10;E6:E10):BUSCARX(C3;B6:B10;E6:E10))

¿Cómo funciona? BUSCARX devuelve un rango en lugar de un valor, por lo que, cuando se calcula, la fórmula tiene un aspecto similar al siguiente: =SUMA($E$7:$E$9). Puedes ver cómo funciona por tu cuenta. Para ello, selecciona una celda con una fórmula BUSCARX similar a esta, ves a Fórmulas > Auditoría de fórmulas > Evaluar fórmula y presiona el botón Evaluar para avanzar por el cálculo.

Nota: Gracias al MVP de Microsoft Excel, Bill Jelen, por sugerir este ejemplo.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios .

Crea tu propio blog con WordPress.com.

Subir ↑

A %d blogueros les gusta esto: